Overview
No contents entries on this page
Contents
Topic functions menu
Menu
This is the first topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

IMAP Extractors is a software product designed to extract attachments, email addresses and messages from IMAP4 folders and to make an archive of the files extracted.

IMAP Extractors is a very convenient and efficient solution. You can use IMAP Extractors to create an archive of attachments or messages received from certain individual and corporate clients, messages with specified subject or, received within certain time interval and make email addresses list from all senders.

IMAP Extractors has the friendly graphic interface and the easy to use wizard will help you to extract data from the IMAP4 folders by several mouse clicks.

Features

·Very simple to use

·Extract e-mail attachments, e-mail addresses and messages from public folders

·Multiple accounts for processing

·Subfolders processing

·Advanced folder naming

·Advanced file naming

·Automatic mode for scheduling

·Save results to text or CSV or MS Excel files

·Can process only new messages with saved projects

·"One-Click" processing with saved projects

How does IMAP Extractors work?

IMAP Extractors scans messages stored in specified folders and subfolders of IMAP4 servers. Then it extracts attachments from the messages and saves them in the specified folder on the disc.

© 2018 EMMA Labs All rights reserved.


Choosing Messages Folder
No contents entries on this page
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

To extract messages by the IMAP Extractors, you should specify a "Messages Folders" where the messages are stored. Multiple selections are allowed.


Select the Output Folder
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

All messages or attachments will be placed into the folder specified below. Also, you can choose what should be done with existing messages - overwrite or skip its. Turn off an option "Include attachments" to store messages without attachments.

If Message Exists

Specify what action is to be taken if a file with message name already exists in the folder messages are saved to.

The following actions are possible:

Skip This Message

Overwrite Existing Message

Create Unique Name for This Message


Choose the Folder Naming

EMMA Labs website

Navigation: Wizard Pages:

Step 3:Choose the Folder Naming
No contents entries on this page
Contents
Topic functions menu
Menu
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

By default, all attachments or messages files are placed into the same directory, but you can group messages in folders by subject, folder name, sender data, counter, system or message date-based format.

Name of Folder

Specify data based on which name of the folder for message extracted is to be created.

The following methods are possible:

Message Folder Name

the folder name is similar to name of the folder in the mailbox

Message Sender Name

the folder name is similar to sender's name in the message under processing

Message Sender Email

the name is similar to sender's address in the message under processing

Message Subject

the folder name is similar to the subject of the message under processing

System Date Format

the folder name is created based on the system time

Message Date Format

the folder name is created based on the time from the message under processing

Counter Format

the folder name is created based on the message number

Date Format

Specify the format to be used for creating folder name based on the date.

Number Format

Specify the format to be used for creating folder name based on the message number.

Started From

Set initial numbering value.

Output Folder Sample

Shows example of folder names that will be created with the chosen settings.

Date format:

Format | Meaning | Example
d | Day of the month as digits without leading zeros for single digit days. | 5
dd | Day of the month as digits with leading zeros for single digit days. | 05
ddd | Day of the week as a three letter abbreviation. | Mon
dddd | Day of the week as its full name. | Monday
M | Month as digits without leading zeros for single digit months. | 1
MM | Month as digits with leading zeros for single digit months. | 01
MMM | Month as a three letter abbreviation. | jun
MMMM | Month as its full name. | June
y | Year represented only by the last digit if the year is less than 10. Years greater than 10 will be given the value of yy. | 9
yy | Year represented only by the last two digits. | 09
yyyy | Year represented by the full 4 digits. | 1909

Time format:

Format | Meaning | Example
h | Hours without leading zeros for single digit hours (12-hour clock). | 1
hh | Hours with leading zeros for single digit hours (12-hour clock). | 01
H | Hours without leading zeros for single digit hours (24-hour clock). | 1
HH | Hours with leading zeros for single digit hours (24-hour clock). | 01
m | Minutes without leading zeros for single digit minutes. | 9
mm | Minutes with leading zeros for single digit minutes. | 09
s | Seconds without leading zeros for single digit seconds. | 5
ss | Seconds with leading zeros for single digit seconds. | 05
t | One character time marker string. This will be the first letter of the values in the AM symbol or PM symbol boxes in Regional Options. | A
tt | Multi-character time marker string. This will be valued in the AM symbol or PM symbol boxes in Regional Options. | AM

Number format:

pre text %[0][width][type] post text

pre text - prefix text

% - enables inserting of text based on the message number

0 - enables leader spaces

width - a number from 1 to 255 that defines the length of the text to be created based on the message number

type - format, possible values are described below.

post text - end text

Possible meanings of the type field:

Format | Meaning | Example
d, i | Signed decimal integer. | 27
o | Signed octal integer. | 33
x | Signed hexadecimal integer, using "abcdef". | 1b
X | Signed hexadecimal integer, using "ABCDEF". | 1B
u | Unsigned decimal integer. | 27

Notes: 1. For using date and time format symbol (d, M, y, h, H, m, s, t, g) in the directory name enter single quote before it.


Choose the File Naming
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

By default, all attachments or messages files have the counter-based format with .eml extension (for messages) or have own (for attachments), but you can name it with your own name format, based on subject, sender data, system or message date. Press "Next" to start extracting data.

Name of Message Files

Specify data based on which name of the file for message extracted is to be created. The following methods are possible:

Message Sender Name

the file name is similar to sender's name in the message under processing

Message Sender Email

the file is similar to sender's address in the message under processing

Message Subject

the file name is similar to the subject of the message under processing

System Date Format

the file name is created based on the system time

Message Date Format

the file name is created based on the time from the message under processing

Counter Format

the file name is created based on the message number

Date Format

Specify the format to be used for creating filename based on the date.

Number Format

Specify the format to be used for creating filename based on the message number.

Started From

Set initial numbering value.

Message File Name Sample

Shows an example of file names that will be created with the chosen settings.

Date format:

Format | Meaning | Example
d | Day of the month as digits without leading zeros for single digit days. | 5
dd | Day of the month as digits with leading zeros for single digit days. | 05
ddd | Day of the week as a three letter abbreviation. | Mon
dddd | Day of the week as its full name. | Monday
M | Month as digits without leading zeros for single digit months. | 1
MM | Month as digits with leading zeros for single digit months. | 01
MMM | Month as a three letter abbreviation. | jun
MMMM | Month as its full name. | June
y | Year represented only by the last digit if the year is less than 10. Years greater than 10 will be given the value of yy. | 9
yy | Year represented only by the last two digits. | 09
yyyy | Year represented by the full 4 digits. | 1909

Time format:

Format | Meaning | Example
h | Hours without leading zeros for single digit hours (12-hour clock). | 1
hh | Hours with leading zeros for single digit hours (12-hour clock). | 01
H | Hours without leading zeros for single digit hours (24-hour clock). | 1
HH | Hours with leading zeros for single digit hours (24-hour clock). | 01
m | Minutes without leading zeros for single digit minutes. | 9
mm | Minutes with leading zeros for single digit minutes. | 09
s | Seconds without leading zeros for single digit seconds. | 5
ss | Seconds with leading zeros for single digit seconds. | 05
t | One character time marker string. This will be the first letter of the valued in the AM symbol or PM symbol boxes in Regional Options. | A
tt | Multi-character time marker string. This will be values in the AM symbol or PM symbol boxes in Regional Options. | AM

Number format:

pre text %[0][width][type] post text

pre text - prefix text

% - enables inserting of text based on the message number

0 - enables leader spaces

width - a number from 1 to 255 that defines the length of the text to be created based on the message number

type - format, possible values are described below.

post text - end text

Possible meanings of the type field:

Format | Meaning | Example
d, i | Signed decimal integer. | 27
o | Signed octal integer. | 33
x | Signed hexadecimal integer, using "abcdef". | 1b
X | Signed hexadecimal integer, using "ABCDEF". | 1B
u | Unsigned decimal integer. | 27

Notes: 1. For using date and time format symbol (d, M, y, h, H, m, s, t, g) in the directory name enter single quote before it.


Select Extracting Options
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

You can extract e-mail addresses not only from sender's data but also from all message headers or from full message's data. Also, during processing, you can remove duplicates based on e-mail address or name. Press "Next" to start extracting.

Extract Addresses From

Selects a source of emails inside of the taken messages. Supports following sources:

Sender Data

Message sender (field "From")

Recipient Data

Message recipient (Field "To")

All Address Fields

All fields of message with right email address

All Message Headers

All message header

Message Body

Only message body without headers

Full Message

Full message with header and body

Duplicates

Establishes a way of ignoring of duplicated addresses and (or) names. Supports following ways:

Ignore Duplicated E-Mails

Ignore Duplicated Names

Ignore Duplicated E-Mails & Names

Do not ignore duplicates


Processing Status
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

You can view the status of e-mail messages processing bellow. Press "Cancel" button to stop the extraction. After processing will be completed you can view extracted e-mail messages or attachments in the "Output Folder". Or export extracted email addresses to file.


Select an Export Format
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

In this page, you can specify the format in which you would like to save Extracted E-mail Addresses. You can save it into the text file or the MS Excel worksheet.


View Results
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Congratulations! All work was done! You have successfully extract data.

Please check "Go To Folder With Extracted Data" and "Finish" to view results.

Also, you can save the Project for the future use.


Registration
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

You can register your copy of IMAP Extractors via registration service using any major credit card. You can register on-line, using fax, toll-free phone, by check or wire transfer. Money orders are also accepted.

On the Internet, go to our Web page and follow the link "Purchase IMAP Extractors".

You can also use the wire transfer to register IMAP Extractors. Please contact EMMA Labs via support for more details.

When you'll register, you'll get the registration key (serial number) which will allow you to save program results. Your registration key will work for all future versions of IMAP Extractors (or we may provide you with the new key if the keys will be changed for some reason).


Unregistered copy limitations
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

The unregistered version of IMAP Extractors is almost fully functional. However, it has some limitations - you can not extract attachments larger than 64Kb (for Attachments mode), "Save" functions are limited (for Addresses mode), you can not extract messages larger than 8Kb (for Messages mode) and you can not use "Process Only New Messages" flag.

Also, we can provide only limited support (and with low priority) to unregistered users.

When you register, you'll get the registration key (serial number) which remove registration screen. Your registration key will work for all future versions of IMAP Extractors (or we may provide you with the new key, if the keys will be changed for some reason).


Technical support
No contents entries on this page
Go to previous topic
Go to home topic
Go to next topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

At the web-site you can find the complete list of our software products and the latest news, download trial versions of the products and register your software.

Most of our products are being updated once a month on the average. Don't forget to visit our site, we are always glad to see you! Should you have any questions or suggestions, please, contact the technical support service.

Our technical support service is always glad to help you and to answer at any your questions. Please, keep to the following rules when contacting the technical support service:

·If your question concerns incorrect operation of the software, do not forget to provide the version number of your operating system, service/upgrade pack, and Microsoft Internet Explorer installed on your computer.

·Please, include any additional details you see appropriate so that the developers could reconstruct your exact situation in the lab.

·If you are registered user, specify your serial number or number of the order. It will help us to process your inquiry faster.

·See the list of latest upgrades in the Internet, the problem might be already corrected in the newer version.


Command line options
No contents entries on this page
Go to previous topic
Go to home topic
This is the last topic

  • Scroll to top of this topic Scroll to Top of Page

  • Print the current topic Print Topic

  • No expanding elements on this page Show/Hide Expanders

Available follow command line parameters:

IMAPE.exe [/log="Log file name"] [/project="Project file name"]

/log="Log file name" - Set path and file name of the log file.

/project="Project file name" - Set path and file name of the project file. This is useful if you want to run project periodically by a scheduled task.